I am trying to run a package on my Raspberry Pi:

At the terminal, I typed in “sudo apt-get install picap” followed by enter.

I get it installed but cannot execute "picap-setup" – instead an error message follows:

pi@raspberrypi:~ $ picap-setup Traceback (most recent call last): File "", line 1, in ImportError: No module named RPi

Python-dev and Rpi.GPIO are installed on the Pi. I also updated the Pi with the latest version with sudo apt-get update and sudo apt-get dist-upgrade.

Picap comes from : https://www.bareconductive.com/make/setting-up-pi-cap-raspberry-pi/

I am thankful for any hints.

  • 339
  • 1
  • 2
  • 4

5 Answers5


First of all, repeat following process

sudo apt-get install python-pip
pip freeze | grep RPi

see what you get after this second command, If you get a valid module for RPi.GPIO or not. And then following if not installed.

For Python 2

sudo apt-get install python-dev python-rpi.gpio


pip install RPi.GPIO

For python3

sudo apt-get install python3-dev python3-rpi.gpio

and then ( for python 2 or python 3):

sudo apt-get install picap

These all worked for me, Just you need to verify pip freeze | grep RPi. And one more thing sometimes some modules are not available for normal user only for root user. Make sure. I did all above using my pi user.

  • 103
  • 3
  • 391
  • 2
  • 6
  • 2
    I would **not** use `pip` to install to system packages, either install from system package manager with `apt` or use `virtualenv` if you want to use pip. – crasic Dec 18 '17 at 17:13
  • Yeah thats correct, agreed – BetaDev Dec 18 '17 at 17:15
  • 2
    For Python3 use `sudo apt-get install python3-dev python3-rpi.gpio`. – Diomidis Spinellis Sep 29 '19 at 15:49
  • @crasic Could you explain why or point me in the direction of an explanation for simpletons? Thanks. – Phill Healey Jan 25 '20 at 20:31
  • I get the following when trying to run picap-setup on my Raspberry Pi 4 with Python 3.7 in a virtualenv: `File "", line 2 print GPIO.RPI_INFO['TYPE'] ^ SyntaxError: Missing parentheses in call to 'print'. Did you mean print(GPIO.RPI_INFO['TYPE'])?`. It seems like this doesn't work with Python 3 – lolsky Dec 02 '20 at 04:34

If Python RPi module is missing, one can install pip with all dependencies and then install the module using pip or go with the better approach and install the module alone:

sudo apt-get install python-rpi.gpio

for Python3 this one:

sudo apt-get install python3-rpi.gpio
  • 161
  • 1
  • 3
  • Some appliances/JeOS doesn't support distro upgrade (like Volumio) and updating and installing a lot of dependencies can break the system, so this is another reason why to go low profile like that. – dmnc Mar 12 '19 at 11:46

For Windows

pip install python3-rpi.gpio


pip install RPi.GPIO
  • 2,720
  • 4
  • 22
  • 36
Dhiren Biren
  • 141
  • 1

I had a similar issue with my Pi. Doing a simple pip install solved the issue.

pip install RPi.GPIO 

if using pycharm on windows then it will work like this

  1. upgrade pip

    C:\Users\sandeep\PycharmProjects\newnum1\venv\Scripts\python.exe -m pip install --upgrade pip

  2. installing the module

    pip install RPi.GPIO

  3. it worked for me should work for everyone

  • 1