My Windows Server 2003 Std server refuses to server ASP.NET content. It serves regular html just fine but anything .net, even a one line html file with an ASPX extention fails silently.

Things I've tried:

  • Nothing in the event log or IIS WWW logs when it fails.
  • Fiddler shows no response
  • I reinstalled .NET with
    • C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -U
    • C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -I
  • I give obscenely high permissions on everything I can think of (full control, read, write, etc.) to all possibly relevant users (IUSER*, ASP.NET, etc.).
  • I confirmed that ASP.Net v1 and v2 Web Service Extensions are "allowed" in IIS
  • Confirmed that the Server Manager had IIS and ASP.Net roles enabled

Again: this is the scenario:

Any guidance will be much appreciated!

Solution: I reinstalled per the instructions below and it works now. Thanks all!

  • 28,508
  • 20
  • 98
  • 148
Michael Haren
  • 1,301
  • 7
  • 18
  • 31

4 Answers4


I've run into this exact issue several times, and every time, the solution was to:

  1. go to the Control Panel
  2. go to the "Windows Components" area
  3. remove IIS, let it uninstall
  4. reboot
  5. re-add IIS (make sure to include the ASP.NET stuff when you check off the boxes).
  6. Run this:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -I

I spent hours debugging this at a client site once, and that was the trick. Since then, every time this has happened, this was the fix.

I'm not sure what the root cause is, but we tore the IIS configuration apart once trying to figure it out, and even had Microsoft RDC'ing into the server in question for 2 or 3 hours, and they couldn't help either.

So I write it off as an undocumented bug in ASP.NET/IIS.

  • 3,037
  • 6
  • 27
  • 40
Sam Schutte
  • 886
  • 2
  • 9
  • 15
  • 1
    That did it. Soooo much time wasted on this with such an unsatisfying solution--I hate not knowing the actual cause. Oh well, it's working now--thanks very much, Sam! – Michael Haren Apr 30 '09 at 22:13
  • 2
    Step 6: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -I – Michael Haren Apr 30 '09 at 22:16
  • No problem - glad to be of service, cause I know this is a painful one! – Sam Schutte May 01 '09 at 19:58
  • Also, it might be that the actual cause is simply a bad install. I know when I've run into this, everything else looks fine, but I assume that somewhere the registry or config is screwed for some reason. – Sam Schutte May 01 '09 at 19:59
  • It might be worth formatting the command in step 6 as code, to make it easier to tell that the flag is an upper-case 'i'. – Dave Andersen Jan 25 '14 at 00:14

Try this: http://localhost/blah.aspx (should be a non-existent page). If it gives you a 404 instead of the asp.net error page then asp.net isn't running, if it gives you a 403 error then the permissions for the site are wrong.

Here's a checklist that may help:

  • Is IIS running?
  • Is your website running?
  • Is the app-pool for your website working correctly?
  • Is ASP.NET installed and registered?

    cd /d %windir%\Microsoft.Net\Framework\v2.0.50727

    aspnet_regiis -ua

    aspnet_regiis -i -enable

  • Is ASP.NET running?

Check the "ASP.NET" tab in your web site's properties. Make sure it's using the right version.

  • Are permissions set up correctly?

Check the "Home Directory" tab in your site's properties, check the "Execute Permissions" setting, it should be set to allow scripts. Also check the "Web Service Extensions" to make sure asp.net is allowed to run.

  • 1,617
  • 12
  • 16
  • This is a nice list for future reference. I'd already tried all that except the -a and -enable switches, and the blah.aspx idea. Reinstalling IIS was what it took. Thanks for the help! – Michael Haren Apr 30 '09 at 22:12
  • What does a correctly running app-pool look like? What does an incorrectly running app-pool look like? – Ian Boyd Jul 15 '09 at 21:20
  • Where does one find the "Web Service Extension" so i can make sure asp.net is allowed to run? – Ian Boyd Jul 15 '09 at 21:22
  • 1
    The "ASP.NET installed and registered?" step did it for me. Though I needed to use a different path to ASP. I used "Framwork64" in the step above cause my system was 64 bit – ScottyG Feb 18 '20 at 21:48

Open the IIS manager, click on Web Service Extensions folder in left pane. Then click on the ASP.NET Extension in the right pane and click Allow button.

  • 375
  • 1
  • 5
  • 15

You don't need to uninstall/reinstall IIS to re-establish .net support, per the previous answer. Just run the aspnet_regiis.exe utility that is located in the appropriate framwork folder, e.g.:

  • 141
  • 1
  • 6