I have been using remote desktop for a number years, on a number of versions of windows, most recently 8.1.

Yesterday I upgraded to 10. I had to download Remote Desktop from the Windows Store. Easy enough. I managed to log into a few of my servers.

No problem. I now need to transfer a package up to one of them. Wait, where is the control to allow mounting of local storage devices ??

If anyone knows where MS has hidden this that information would be greatly appreciated!

  • 103
  • 6
  • 403
  • 1
  • 4
  • 6
  • 5
    Does copy/paste work? – Jim G. Aug 13 '15 at 16:55
  • @Jim G. No, clipboard only works for text. – Suncat2000 Aug 04 '17 at 18:46
  • @Suncat2000 Copy/paste works fine for files if you copy from Windows Explorer to Windows Explorer (local -> remote or remote -> local). The only trick is that you can't copy something else while the file is being transferred, or that file transfer will be interrupted with an error. – Bruno Apr 08 '20 at 18:16

4 Answers4


Copy+paste works for me, in both directions

For example, to move a file from local --> remote, minimize Remote Desktop and copy the file on your local machine, then open Remote Desktop and paste the file.

  • 1,096
  • 1
  • 11
  • 18
  • Saved my day! I am not very used to developing on Windows, and this was quick + easy. – Arka Mukherjee Jul 16 '21 at 17:01
  • For me it was an issue where MacOS it's CMD + C to copy but on Windows it's CTRL + V to paste (rather than CMD + V). To be sure just go ahead and manually copy and paste, without using shortcuts – sdooo Mar 29 '22 at 10:19
  • In 2022 this works out of the box for RDP on Win 10, but NOT drag and drop just to be clear. RDP != VMWare or VirtualBox – Drakes Jun 14 '22 at 04:26

When you are configuring your remote desktop connection, there is an option that is labelled 'local resources' from there you can pass through local drives to the target machine.

You shouldn't have needed to install remote desktop from the store since the client is included by default. In the search box on the taskbar, type remote desktop and it will appear in the results, open it and click the show options button. You will then see local resources.

This is the same as every previous version of windows in the past 14 years I believe. Unless you have downloaded another type of rdp client.

  • 1,011
  • 1
  • 12
  • 24
  • I recall doing a local search for this and it came back with nothing. That led me to the store. – scopedial Aug 13 '15 at 17:01
  • 2
    It might be that non-Pro or Enterprise editions of 10 don't include mstsc. On the Local Resources tab, click the **More...** button near the bottom to connect local drives. – Todd Wilcox Aug 13 '15 at 17:04
  • 3
    I dug deeper into the list of "accessories" and the old remote desktop is still there. I am now using that. Thanks! – scopedial Aug 13 '15 at 17:11
  • 2
    The old Remote Desktop Connection app has these options and allows clipboard operations between your local and remote desktops as well as sharing drives. The new Remote Desktop app, which has built-in session management, does not (it will clip text, but that's about as advanced as it gets). They are not the same. – Suncat2000 Aug 04 '17 at 19:28
  • No drives are available if I use `mstsc.exe` from within an Oracle VirtualBox [v6.0.10 r132072 (Qt5.6.2)] Win 10 VM, despite of selecting everything under _Local Resources_ → _More..._ → _Drives_ in the RDP connection. – Gerold Broser Aug 28 '19 at 14:18
  • Where would these extra drives appear? – Meekohi Oct 07 '20 at 14:07

Since the question was how to transfer using the windows 10 app vs the desktop program:
To transfer files I use the \\c$ method (where the IP address is for the other machine). It is fast and reliable. I have a folder with c-drive shortcuts to all of the machines I remote to. I prefer the Windows Store RDC client for Windows10 clients.

  • 31
  • 1

In this situation, I would recommend using other remote access applications, such as Igiko Management Tools or AnyDesk. The process of remote file transfer there is pretty simple.

  • 1