Questions tagged [permissions]

Permissions define the operations that authenticated users are allowed to perform on file systems, databases and other computer systems.

Permissions are a series of rules that defines the action that authenticated users of computer systems can do. Permission are employed in several systems, such as file systems, DBMS, apps (iOS, Android, Windows Store, ...) and claims-based identity.

From a programming perspective, we are not interested in how to assign permissions in a particular context (i.e. in a company) but in how these are implemented (which permissions are implemented, in which way we combine them, how they impact performance, ...).

This tag should be used:

  • for questions about how permissions work in a particular systems;
  • for scenarios/problems that involves permissions in a substantial way.

This tag should not be used for asking about the specific permissions that should be assigned in a particular scenario.

Related tags: , , ,

17586 questions
36 answers

ssh "permissions are too open"

I get the following error from ssh: Permissions 0777 for '/Users/username/.ssh/id_rsa' are too open. It is recommended that your private key files are NOT accessible by others. This private key will be ignored. What permissions should I give to the…
Yannick Schall
  • 32,601
  • 6
  • 29
  • 42
19 answers

How do I change permissions for a folder and its subfolders/files?

How do I change the permissions of a folder and all its subfolders and files? This only applies to the /opt/lampp/htdocs folder, not its contents: chmod 775 /opt/lampp/htdocs How do I set chmod 755 for all of the /opt/lampp/htdocs folder's current…
Adam Halasz
  • 57,421
  • 66
  • 149
  • 213
39 answers

How to fix npm throwing error without sudo

I just installed node and npm through the package on, and whenever I try to search or install something with npm, it throws the following error unless I sudo the command. I have a feeling this is a permissions issue? I am already the…
  • 18,076
  • 8
  • 31
  • 41
15 answers

How do I use sudo to redirect output to a location I don't have permission to write to?

I've been given sudo access on one of our development RedHat linux boxes, and I seem to find myself quite often needing to redirect output to a location I don't normally have write access to. The trouble is, this contrived example doesn't work: sudo…
  • 25,873
  • 13
  • 66
  • 85
43 answers

"UNPROTECTED PRIVATE KEY FILE!" Error using SSH into Amazon EC2 Instance (AWS)

I've created a new linux instance on Amazon EC2, and as part of that downloaded the .pem file to allow me to SSH in. When I tried to ssh with: ssh -i myfile.pem I got: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ …
Matt Roberts
  • 26,371
  • 31
  • 103
  • 180
7 answers

Chmod 777 to a folder and all contents

I have a web directory /www and a folder in that directory called store. Within store are several files and folders. I want to give the folder store and all files and folders within the store folder all permissions. How do I do this? I am guessing…
  • 14,540
  • 34
  • 97
  • 144
15 answers

sudo echo "something" >> /etc/privilegedFile doesn't work

This is a pretty simple question, at least it seems like it should be, about sudo permissions in Linux. There are a lot of times when I just want to append something to /etc/hosts or a similar file but end up not being able to because both > and >>…
  • 17,673
  • 10
  • 68
  • 97
24 answers

How to reset Django admin password?

I am using Django (version 1.3) and have forgotten both admin username and password. How to reset both? And is it possible to make a normal user into admin, and then remove admin status?
  • 6,602
  • 4
  • 19
  • 17
7 answers

How to create file execute mode permissions in Git on Windows?

I use Git in Windows, and want to push the executable shell script into git repo by one commit. Usually I need to do two steps (git commit). $ vi $ git add $ git commit -am "add new file for installation" # first…
Larry Cai
  • 55,923
  • 34
  • 110
  • 156
25 answers

SSH Key: “Permissions 0644 for '' are too open.” on mac

I generate a ssh key pair on my mac and add the public key to my ubuntu server(in fact, it is a virtual machine on my mac),but when I try to login the ubuntu server,it says: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ …
  • 6,175
  • 3
  • 14
  • 16
41 answers

MySQL error 1449: The user specified as a definer does not exist

When I run the following query I get an error: SELECT `a`.`sl_id` AS `sl_id`, `a`.`quote_id` AS `quote_id`, `a`.`sl_date` AS `sl_date`, `a`.`sl_type` AS `sl_type`, …
Tech MLG
  • 5,777
  • 4
  • 17
  • 7
4 answers

IIS AppPoolIdentity and file system write access permissions

Here's an issue with IIS 7.5 and ASP.NET that I've been researching and getting nowhere with. Any help would be greatly appreciated. My question is: using ASP.NET in IIS 7.5, how does IIS and/or the operating system allow the web application to…
  • 27,021
  • 9
  • 71
  • 75
8 answers

IIS7 Permissions Overview - ApplicationPoolIdentity

We have recently upgraded to IIS7 as a core web server and I need an overview in terms of the permissions. Previously, when needing to write to the file system I would have give the AppPool user (Network Service) access to the directory or file. In…
  • 18,243
  • 19
  • 75
  • 116
5 answers

ERROR: permission denied for sequence cities_id_seq using Postgres

I ran following sql script on my database: create table cities ( id serial primary key, name text not null ); create table reports ( id serial primary key, cityid integer not null references cities(id), reportdate date not null, reporttext text not…
Tõnis Ojandu
  • 3,486
  • 4
  • 20
  • 28
25 answers

Android M Permissions: onRequestPermissionsResult() not being called

I'm updating our app to use the new M runtime permissions system. It's all working except for onRequestPermissionsResult(). I need to check a permission on a button press, and if it's successful, send a text message. When I grant permission to do…
  • 5,099
  • 7
  • 29
  • 51
2 3
99 100